logo_large_6499I’d like to open this post up to some discussion about printing coupons from SmartSource.com.  We’ve received some mail indicating that many of you are having trouble printing from this source.  With over a hundred HOT coupons, the savings at SmartSource are too hot to pass by.  So for those of you who are having trouble, be specific and let’s see if we can help each other figure this out!  (Please if any of you readers out there techies or really computer savvy, we’d love your input!  I’ll do my best to research your issues and find solutions!)  Check out this resource as well:
Smartsource Troubleshooting Guide

Please limit your discussions to printing problems about SmartSource only.  If you’d like help printing from another source, let us know, but we’ll try to conquer them one at a time!

So tell us, Can you print SmartSource coupons?
And if not, where do you get stuck?

Leave a Reply

48 thoughts on “Speak up! SmartSource Printing Trouble!”

  1. mrs says:

    Java gives me compatibilty trouble about 50% of the time on this site. I REALLY wish they would address it bc it is a huge problem for many. Further– It really aggravates me to spend my time hunting out coupons to have them not print… then be told I have reached print limits.

  2. Melindanelson2010 says:

    I have been trying to print coupons from smart source. Problem is, its stating that I need to enable Java. However, Java is installed. I have checked and I have the most current version (6). The Smart Source site states it has to be version 5. I have tried everything, but cannot figure it out. Please Help!

  3. Melindanelson2010 says:

    I have been trying to print coupons from smart source. Problem is, its stating that I need to enable Java. However, Java is installed. I have checked and I have the most current version (6). The Smart Source site states it has to be version 5. I have tried everything, but cannot figure it out. Please Help!

  4. Heather says:

    I just came across this post that Joanie did awhile ago, it’s not smartsource specific but it may help some of you

    http://thekrazycouponlady.com/2009/05/trouble-printing-coupons.html

  5. Caroline says:

    I get the java message and then sometimes the “Please ensure your printer is turned on and the printer is connected to your computer. Verify that you have paper and ink.” I’d say my success rate with Smartsource is 50%, so I often don’t even bother. It’s annoying.

  6. Tera says:

    I get a message that java is not installed on my coputer! I did install it but it still does not work. I think my problem lies in java and not SS. So I cannot print anything or do anything when Java is involved!

  7. CJ says:

    I’ve always had trouble with SmartSource, using IE and AOL. I’ve downloaded the most recent version of Java, everything is enabled, I dont think I have a firewall, etc. I just get the spinning Java thingy and it doesn’t print. On the very few occasions they have printed, they print without the bar code.

  8. Kathleen says:

    Ditto on #34, Nikki… click tools, then enable java…
    If it doesn’t print the first time, I close the internet, reopen, go back to SS, select the coupons I want and click tools, etc before I hit print

  9. Jessica says:

    I have the same problem that Lisa (from a previous post above) has. When I go to print the SmartSource coupons, it will act like the coupon is printing, but then it will only be a very small picture of the item and not the coupon. Gets rather annoying… maybe I will be able to figure out what the problem is. Anyone have any suggestions on how to get the SmartSource coupons to print correctly using Internet Explorer? Any help or suggestions is greatly appreciated.

    Thanks!
    Jessica

  10. Chef Likes says:

    I have had the same problems as above. I am using IE. And it tells me to enable Java. After going through all the troubleshooting steps,it all ready is enabled. And still doesn’t work. My Hubby says NO WAY to disabling the firewall. We have tried downloading “current” version of Java, but still get that message. No SS for us, right now. Please post if you hear of ANOTHER solution.

  11. Nikki says:

    Annie in comment 23, I get that message often (the “please wait” message but never prints). The problem for me when I get that message is I clicked on the link to the coupon that is for IE and I use FF. So my FF has a button that my husband added that switches that tab to IE while running in FF and it prints. If you don’t have that button, copy the link into IE and it will print.

    As far as the Java not enabled problem, I get that message all the time from SS, and I still use FF. What I do is go into Tools>Options>Content then uncheck “Enable Java” then recheck “Enable Java.” Then I reprint the coupon and it prints. Sometimes it will work for several prints in a row, but sometimes I have to do that repeatedly in a day. Annoying but it works. On a side note, it depends on which version of FF you have, if you have a different version, then you’ll have to take a different route to get to enabling java.

  12. Jenny says:

    I usually have to try twice to get SmartSource coupons to print. Usually is will come back with a java error and if I do the back arrow in the browser it will print the next try. Sometimes if it doesn’t print in FF I can copy and paste the link into IE and it does work…consistently working would be nice of course!! But I usually am able to get the coupons I want, just have to work around the system a bit…

  13. Kristen says:

    I always have to switch to IE before printing and then my coupons print without any problem. But in Safeway 3 days ago, I was using some of the SmartSource printables and the cashier said the machines were having a hard time accepting them so they might not be able to take them anymore. This was news to me and I hope it doesn’t happen since so many great deals can be found at Safeway with printables.

  14. Andrea says:

    I print them with FF all the time but on occasion it will say I have already reached my print limit when I KNOW I haven’t. Or the coupons don’t reset for me but they do for other people.

  15. Shelley says:

    I was doing fine until recently when I changed to Google Chrome. Now it just says “please wait”, but nothing else really happens. I reloaded JAVA like it prompted. went into my browser to enable it, everything is right, but NO PRINTS! Sometimes I can get ‘em to print in firefox BUT it’s not foolproof. FRUSTRATING!

  16. Anna says:

    After reading all the comments – I feel better. I thought I was the only one struggling with SS. They need to do something about it!

  17. dani says:

    I can’t print most of the time in any browser. I usually use FF, but I have tried IE and Google Chrome. I’ve tried on numerous computers. I get both messages- Java not enabled and Reached print limit. My husband is a computer techie and he wasn’t able to figure it out for me either.

  18. christi says:

    I’m a Mac user and I can only print them on Safari (never with Firefox) and I often get the Java mumbo-jumbo and of course all of my preferences are set correctly. Strange.

  19. Yori @qponner.blogspot.com says:

    I too have a macbook and CANNOT print and SS coupons from it. I have tried different things but still no luck. Totally annoying!! Maybe we should send all these complaints on to SS! :)

  20. Kathy says:

    I have two Mac’s. The intel will print SS IF I use FF. The imac (not an intel) will not print using FF or Safari. Both computers using same os 10.5.8 Have done all the trouble shooting suggestions… no luck. :( Would love to be able to print SS.

  21. Robin says:

    I can’t print anything linked to smartsource. It requires Java–which I have–but the stupid IE 7 & 8 will not recognize it. I have tried all the patches and fixes on the net w/ no relief. I wish smartsource would do something about this and offer a different printer application!!!

  22. Annie says:

    SmartSource has been iffy for me lately, glad I’m not alone! I do fine all the way thru to printing, then is just says ‘please wait’ and that screen never goes away, and nothing prints. This happens about half the time I try to print. I have read and reread the troubleshooting guide (been doing this for, oh, nine months or so?), sent emails with specifics to the company, but each time I get the same canned response, which is a word for word replay from the troubleshooting guide, WHICH I ALREADY READ, and almost know by heart now. I do sometimes have issues with coupons.com as well. Thank you for addressing this issue, darlings!

  23. aubs says:

    I use FF and have never been able to print from SS. Half the time it says that java was probably not enabled and walked me through the process to enable it (which I did) but it still doesn’t work. The other half of the time it acts like it’s going to print and then pops up saying I have already printed this coupon (which I know for certainty I have not).

  24. Kara says:

    Can’t print from either FF or IE. In FF I got a picture of the item, no coupon. In IE I get the Java not enabled message.

  25. Susan says:

    I temporarily allow pop-ups, or you can train your computer to allow pop-ups from a certain website, and it let the SS coupons print when before they didn’t..hope this helps.

  26. I CANNOT print SS coupons in my AOL browser…however, if I go into IE I have no problem at all. But I get so annoyed with myself when I forget and get all jammed up in my AOL browser (and possibly *gasp* waste a printable!!)
    I love SS coupons!!

  27. kristina says:

    after reading the above coments i too have had many of the same experiences

  28. kristina says:

    for me if i try to print more than one coupon at a time…clip more than one coupon the S spins and spins for hours and nothing more happens…sometimes i wake up the next day to find the coupons have printed other days i just exit out and forget about them. it does seem that if i remember to only clip one coupon and print it out the system seems to work okay slow but it works

  29. Moe says:

    I have the same problem as Debbie. I just don’t get those coupons. I enable and then disable, download Java and then repeat in a different order. Nothing works. I am bummed about it. Fortunately most of the coupons I need aren’t from SS.

  30. Bethany Rohdy says:

    I can only print them in Explorer.

  31. Kathy Peters says:

    Does not work for me, even after trying to troubleshoot. It is so frustrating.

  32. Mary Lou says:

    Coupons printed but I also go a msg that I have never seen before. It was “Fraudelent attempt to print detected”. “You may only print coupons from Internet on a SmartSource enable website.”

    I don’ know what that meant but the coupons printed.

    • Joanie Demer says:

      I sometimes get that message if I hit the back browser to attempt a second print. If I get the message, I just return to KCL, click the smartsource link again and print the coupon again.

  33. Joanie Demer says:

    Who’s using Firefox and who’s using Internet Explorer? I’ve heard that if you’ve installed Java and you’re still getting the message that “you need to install Java”, try switching browsers (from IE to FF or vice versa).

  34. Taia says:

    With a Macintosh 10.4 operating system, I can’t print smartsource coupons at all. This may have to do with the interaction between Java and my printer driver. I used to be a printer engineer. Smartsource sends the print file to my printer, but then my printer driver has an error and I have to manually delete the file from the print queue to print anything else. From reading, I believe this is because Smartsource doesn’t follow all the Java and printer driver norms. I was frustrated when I couldn’t print the Huggies Overnites coupons and contacted Kimberly Clark asking them to ask smartsource to fix their software to follow printer driver and Java norms. So, it could be your operating system, your browser, your printer driver OR your printer- a troubleshooting nightmare.

  35. Jennifer Kowal says:

    i always go the message about not having java enabled even though it was. i just went to the java website and downloaded java again and now it lets me print the coupons. sometimes it still comes up but then goes away and the coupon shows up.

  36. Lindsay says:

    How do you turn off and on a firewall!? I am getting that same message and am so bugged when I can’t get a great coupon to print!!

    • Joanie Demer says:

      Well, my firewall is Zone Alarm. So that’s what I have to turn off. You’ll have to learn what software you have on your computer.

  37. Lisa says:

    When I print from the smart source website, it prints a picture of the item, but not the coupon.

  38. debbie says:

    Yes, i can never print their coupon cuz it tells me I don’t have my java enabled. I check my preferences and they’re always enabled so I just give up and don’t print them.

  39. J.J. Ordway says:

    I ALWAYS have trouble with SS coupons. I have tried in FF, IE, and Qwest browsers and still get the same trouble. I get a message saying something about not having java enabled or the right version of java and that they cant print my coupons (IE, Qwest). In FF, I click the coupon I want to print and hit Print…then all windows of my browser shut down. *poof* gone. I have researched this online and found LOTS of ideas, but none work.

    I have come across trying to print a coupon that I know 100% I have never printed before and it says I have already printed my limit.

    Hope this can be resolved soon!

    • Alaina says:

      I also have tried lots of different methods to try and print for smart source, I cant print coupons through albertsons website either because they go through smart source. It gives me a range of errors each time I try usually its that I don’t have the privilege to install it, but I’m the administrator on my computer??

  40. Rachel says:

    I was having trouble printing coupons from SS. It said that probably java was not enabled and walked me through the process but it was enabled and still would not print. I complained to DH. He turned off the firewall on the computer and then I had no problems.

    Don’t know if that helps or not but maybe some of you it will.

    • Joanie says:

      Firewall was my problem when I first tried to print from SS. Either we turn down our firewall or I turn off the program completely, go directly and print my coupons, then REMEMBER to turn the firewall back on.

      I’ll get reading on the java stuff and try to help answer some other questions soon!

  41. Amanda says:

    Smartsource always tells me the java isn’t installed when I use Firefox. I have to keep hitting the back button until it finally goes. I don’t have any problems with Internet Explorer. It is really, really slow to load the coupons. Don’t give up they will print…eventually.

  42. Karen says:

    Forgot to mention there is a lot of info on that troubleshooting link you gave. On one of the questions it had a link to a test coupon ( http://test.coupons.smartsource.com/Web/index.aspx?Link=VGI2SMXMJD5JO ) you could print to test with…but it comes up as:

    ‘Sorry, but the print limit on this offer has been reached.’

    Ha ha…for some reason that cracked me up.

  43. K says:

    SmartSource? How about coupons.com? I have a heck of a time getting things to print from *that* site :(

    I have done everything I know to do but still is is a *huge* problem for me…..

  44. Karen says:

    I don’t often have trouble with SS coupons but every now and then I get a message saying something about not having java or the right version of java and that they cant print my coupons. I retry (I can’t remember if I hit the back button or reload). And I am then able to print and it did not affect being able to get my 2 prints of each.

    Also I have come across trying to print a coupon that I know 100% I have never printed before and it says I have already printed my limit.

    SmartSource is very slow to load up the coupons at least on my computer esp in comparison to the other sites so be patient.